Security & AV

Global “brute force” attack on WordPress websites

wordpress-logoWe have been made aware of a global distributed attack on webservers around the world which host WordPress websites.

It’s not yet known who is behind the attack, which is currently using more than 90,000 IP addresses to attempt to brute force the default admin user credentials of WordPress powered websites around the world. The attack does seem to be coming from a cluster of “botnet” infected computers.

This attack is not limited to any single webhost (including ourselves), but rather a global event could affect any web host.

As a responsible host, we would like to make you aware of this global issue and how you can help protect your own WordPress website from becoming affected.

What you can do to mitigate the botnet attack

1) Avoid simple or obvious passwords

Choose a long password with a mix of numbers, letters (upper and lowercase) and special symbols (!£$%& etc)

An example of a poor password: mypass

An example of a good password: vg^jhgHG57

A strong password is important as a “brute force” attack attempts to log in using the Admin username and random dictionary “wordlists” (many thousands of words etc). By making the password completely random, it is less likely to be on one of these lists.

2) Change the “admin” username

All WordPress sites have the administrator username as “admin” by default. Knowing a correct username is half the puzzle solved for brute forcing. If you change the username to a different name, the botnet not only has to guess your password, but also the username.

3) Keep plugins up to date

When you log into your WordPress site, look out for any updates available – if they are, update them! Often, the updates will be to fix problems and security issues such as “backdoors”. Many hackers exploit holes that have ben identified in older versions of WordPress and it’s plugins.

4) Install the “Limit Login Attempts” plugin

This plugin (available from your WordPress control panel or here) limits the number of login attempts can be made. If the limit is breached, the IP address is automatically blocked for a few minutes. If the limit continues to be breached, the IP is permanently blocked. This is an extremely effective defence against brute force hacking.

5) ADVANCED: Block the admin login page to everyone but your own fixed IP

If you only access your WordPress admin login from a single network and have a static IP address on your connection, you can add this to the .htaccess file in your WordPress installation:

<FilesMatch "^wp-login.php$">
 Order Allow,Deny
 Allow from xxx.xxx.xxx.xxx
 Deny from all
</FilesMatch>

 

Be wary of fake LinkedIn emails

We have noticed a sharp increase in fake LinkedIn invite emails in the last few days.

If you get a LinkedIn invite, we suggest you don’t click any of the links in the email. Instead, log into your LinkedIn account using http://www.linkedin.com and check if the invites are genuine.

Here is an example of the fake emails:

Fake LinkedIn email

Microsoft urges users to install critical RDP patch

Businesses using versions of Windows from Windows XP Service Pack 3 onwards should patch a critical flaw in the software as a matter of priority, say security professionals.

Microsoft brought out a patch for the flaw on Tuesday, documented in the MS12-020 security bulletin. Hackers could use the vulnerability to take control of a computer system by sending malformed Remote Desktop Protocol (RDP) packets over the internet.

Caused by the way RDP treats an improperly initialised or deleted object in memory, the bug affects Windows XP Service Pack 3, Windows XP Professional x64 Edition Service Pack 2, iterations of Windows Server 2003 and Server 2008, Windows Vista SP2, and Windows 7.

“The vulnerability itself is accessible through the network, does not require authentication and allows code execution on the targeted machine, a highly prized combination by attackers,” said Qualys chief technology officer Wolfgang Kandek in a blog post.

“Microsoft has rated its exploitability index as 1, meaning that they expect working exploits to be out in fewer than 30 days,” he added.

Microsoft patched seven vulnerabilities with six patches on Tuesday, according to its March security bulletin. Businesses should concentrate on patching the MS12-020 RDP vulnerability, said Kandek.

“All of your focus should be on MS12-020,” said Kandek. “Within the week apply the patch on your Windows machines that are running the RDP service and are internet facing.”

RDP is popular among businesses for remotely controlling Windows machines, but is not active by default, said Kandek.

“[RDP] needs to be configured and started by the system’s owner, which then makes the vulnerability accessible,” said Kandek. “Consequently we expect that only a relatively small percentage of machines will have RDP up and running.”

Microsoft said in its bulletin that the MS12-020 patch was pushed out through automatic updates.

“Customers who have not enabled automatic updating need to check for updates and install this update manually,” said Microsoft.

“All of your focus should be on MS12-020,” said Kandek. “Within the week apply the patch on your Windows machines that are running the RDP service and are internet facing.”

RDP is popular among businesses for remotely controlling Windows machines, but is not active by default, said Kandek.

“[RDP] needs to be configured and started by the system’s owner, which then makes the vulnerability accessible,” said Kandek. “Consequently we expect that only a relatively small percentage of machines will have RDP up and running.”

Microsoft said in its bulletin that the MS12-020 patch was pushed out through automatic updates.

“Customers who have not enabled automatic updating need to check for updates and install this update manually,” said Microsoft.

All Posilan supported PC’s and servers have already been updated as part of our proactive support service.

Via: ZDNet

Google Js/Blacole.BW alert issue

We have been made aware that some people visiting Google at the moment are getting malware alerts warning that the web page is infected with “Js/Blacole.BW”.

We believe this to be a false positive being generated by a Microsoft Forefront and Microsoft Security Essentials update a short while ago and at time of writing don’t think there is any cause for concern.

Microsoft have just stated that they have removed the problem virus definition and a new virus definition update (1.119.1986.0 or greater) will be available shortly to fix the issue.

There is some discussion about it here on the Microsoft Technet forums and we will update this page with any further relevant updates.

UPDATE 08:30 15th Feb 2012:

This has now been resolved by updating your software to the latest virus definitions. The “false positive” was caused by an erroneous virus definition in update 1.119.1972.0. This was fixed in update 1.119.1988.0 which was released at approximately 3am this morning. It seems the cause if the false positive was Microsoft Forefront and Microsoft Security Essentials mistaking Google’s Valentine’s day “Doodle” as a virus.

Trendnet IP webcam security vulnerability found

Feeds from thousands of Trendnet home security cameras have been breached, allowing any web user to access live footage without needing a password.

Internet addresses which link to the video streams have been posted to a variety of popular messageboard sites.

Users have expressed concern after finding they could view children’s bedrooms among other locations.

Trendnet says it is in the process of releasing firmware updates to correct a coding error introduced in April 2010.

It said it had emailed customers who had registered affected devices to alert them to the problem.

However, a spokesman told the BBC that “roughly 5%” of purchasers had registered their cameras and it had not yet issued a formal media release despite being aware of the problem for more than three weeks.

“We first became aware of this on 12 January,” said Zak Wood, Trendnet’s director of global marketing.

“As of this week we have identified 26 [vulnerable] models. Seven of the models – the firmware has been tested and released.

“We anticipate to have all of the revised firmware available this week. We are scrambling to discover how the code was introduced and at this point it seems like a coding oversight.”

Mr Wood added that the California-based firm estimated that “fewer than one thousand units” might be open to this threat in the UK, but could not immediately provide an exact global tally beyond saying that it was “most likely less than 50,000”.

Feed links

An internet blog first publicised the vulnerability on 10 January.

The author discovered that after setting-up one of the cameras with a password its video stream became accessible to anyone who typed in the correct net address.

Trendnet says it is in the process of releasing firmware updates for its devices

In each case this consisted of the user’s IP addresse followed by an identical sequence of 15 characters.

The writer then showed how the Shodan search engine – which specialises in finding online devices – could be used to discover cameras vulnerable to the flaw.

“Last I ran this there was something like 350 vulnerable devices that were available,” the author wrote at the time.

However, it appears that others then took advantage of the technique to expose other links and uploaded them to the net.

Within two days a list of 679 web addresses had been posted to one site, and others followed – in some cases listing the alleged Google Maps locations associated with each camera.

Messages on one forum included: “someone caught a guy in denmark (traced to ip) getting naked in the bathroom.” Another said: “I think this guy is doing situps.”

One user wrote “Baby Spotted,” causing another to comment “I feel like a pedophile watching this”.

Some screenshots have also been uploaded.

Warning users

At the time of writing Trendnet’s home page and its press release section made no mention of the problem.

However, its downloads page does list a number of “critical” updates with a brief release note saying that the code offers “improved security”.

The firm – whose slogan is “networks that people trust” – said that it had halted shipments of affected products to retailers and that any delivery received since the start of this month should be safe. However, it said that items delivered at an earlier date might need a firmware update.

“We are just getting to that point to be able to succinctly convey more information to the public who would be concerned,” added Mr Wood.

“We are planning an official release of information to the public concerning this, but in advance I can tell you that this week we are targeting to have firmware to all affected models.”

Via: BBC News